Cloud Email Issues
Incident Report for Webcentral Service Status
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 14:21 AEDT
Monitoring
We'd like to inform our Cloud Email customers that emails can now be received.

Our Technicians have worked to resolve this issue and will continue to monitor this issue so that it doesn't happen again.
Posted Nov 17, 2020 - 16:49 AEDT
Investigating
We would like to inform customers of Cloud Webmail issues that we are experiencing. Customer affected are currently unable to receive emails.

To identify if you're affected please check your MX records. The affected MX records are "mx.netregistry.net" & "mx4.netregistry.net".

We appreciate your patience while our technicians work to resolve this as fast as possible.
Posted Nov 17, 2020 - 13:36 AEDT
This incident affected: Website & Email Hosting (WordPress Hosting).