Customer Service Alert
Incident Report for Webcentral Service Status
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 09:38 AEDT
Monitoring
Our support team staffing levels are currently impacted which may result in longer waiting times on our phone lines and live chats, if your matter is not urgent, please submit a Support Enquiry through the Contact Us page.

https://www.netregistry.com.au/contact-us/

We are doing everything we can to return to normal services and appreciate your patience
Posted Nov 12, 2020 - 10:12 AEDT
This incident affected: Support Center (Live Chat, Web/Email Support Enquires).