Netregistry Shopping Cart is not loading
Incident Report for Webcentral Service Status
Resolved
This incident has been resolved.
Posted Mar 02, 2021 - 15:32 AEDT
Update
We are continuing to investigate this issue.
Posted Mar 02, 2021 - 14:45 AEDT
Update
We would like to advise that we are currently experiencing technical difficulties with our Netregistry Website Shopping Cart, which is affecting new customer's ability to search and buy domains. Existing customers are not affected and can order through their accounts.

We are currently investigating the issue and working to resolve this urgently.
Posted Mar 02, 2021 - 14:45 AEDT
Investigating
We would like to advise that we are currently experiencing technical difficulties with our Netregistry Website Shopping Cart, which is affecting customer's ability to search and buy domains. We are currently investigating the issue
Posted Mar 02, 2021 - 14:30 AEDT
This incident affected: Network Infrastructure (Internal Network).